Jump to content

Help
Rate Article   * * * * * 10 votes

Posted Image

NOTICE REGARDING THE UPDATE:

Due to a bug, the previous game launcher will not update correctly. Make sure to download the new, fixed launcher, by clicking here!

ALTERATIONS:
  • Nano gas now heals when it reaches the target and not before.
  • Nerfed pipe gun slightly
  • Reduced revolver and cobra recoil slightly
  • Simplified jetbike interface for now.
  • Increased the no-effect temperature area. -10 to +30 does create any temperature effect,
  • Air-bomb no longer has self destruct by default. Now shows weapons on actor when used.
  • Made an actor with self destruct equipped flash red in intervals.
  • Optimized sprite loading system. Less stuttering in certain conditions.
  • Moved default holster key to shift.

BUG-FIXES:
  • Shield belts no longer eat up all the batteries
  • Fixed crash related to ai trying to get an ai attack range that was nil
  • Fixed crash related to certain actors trying to throw items when they had no custom throw settings
  • Fixed generic object -> object collision position error which would especially affect plasma bullets making them behave erratically by flying away far down right.
  • Fixed nano dispenser explosion being incorrect.
  • Fixed upgrade prices being incorrect and insufficient volt red marking also being incorrect.
  • Fixed end all offers crash
  • Fixed converter delivery crash
  • Fixed a rather broken Hero Laser
  • Fixed itemspawner tile not working correctly.
  • Fixed vendor price indicator being outside with high prices
  • Fixed airbomb not maintaining hover height in non-combat modes
  • Fixed demo crashing when not logged in
  • Fixed missing map in demo list, added a bunch of others.
  • Fixed nondefault vendor price displayed amount not matching actual price.
  • Reduced the inherited speed loot get from actors
Posted in: News
Promoted from v122 Ready For Play!

Comments

#1 Tim_Kb

    Space Captain

  • Members
  • PipPip
  • 38 posts

Posted 03 July 2013 - 09:21 PM

First of all, love the game and have been playing it on my desktop computer for a while. Now with the mac version update, I've been eager to try it out on my laptop. :)

For some reason I can't launch the mac version though.
I'm running 10.6.8 on my macbook pro.

It gives me the following error message: "Check with the developer to make sure Cobalt works with this version of Mac OS X. You may need to reinstall...."

When I click the "show details" button it gives me the following information.

[spoiler]
Process: Cobalt [17635]
Path: /Applications/Cobalt.app/Contents/MacOS/Cobalt
Identifier: com.oxeye.Cobalt
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [103]

Date/Time: 2013-07-03 23:12:10.118 +0200
OS Version: Mac OS X 10.6.8 (10K549)
Report Version: 6

Interval Since Last Report: 17741325 sec
Crashes Since Last Report: 196
Per-App Crashes Since Last Report: 5
Anonymous UUID: BAA968E5-B9B4-492F-9E8C-A0E2B1A1B91A

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /usr/lib/libcurl.4.dylib
Referenced from: /Applications/Cobalt.app/Contents/MacOS/Cobalt
Reason: Incompatible library version: Cobalt requires version 7.0.0 or later, but libcurl.4.dylib provides version 6.0.0

Binary Images:
0x8fe00000 - 0x8fe4162b dyld 132.1 (???) <1C06ECD9-A2D7-BB10-AF50-0F2B598A7DEC> /usr/lib/dyld

Model: MacBookPro7,1, BootROM MBP71.0039.B0B, 2 processors, Intel Core 2 Duo, 2.4 GHz, 4 GB, SMC 1.62f6
Graphics: NVIDIA GeForce 320M, NVIDIA GeForce 320M, PCI, 256 MB
Memory Module: global_name
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x8D), Broadcom BCM43xx 1.0 (5.10.131.42.4)
Bluetooth: Version 2.4.5f3, 2 service, 19 devices, 1 incoming serial ports
Network Service: AirPort, AirPort, en1
Serial ATA Device: Hitachi HTS545025B9SA02, 232,89 GB
Serial ATA Device: HL-DT-ST DVDRW GS23N
USB Device: Built-in iSight, 0x05ac (Apple Inc.), 0x8507, 0x24600000 / 2
USB Device: Internal Memory Card Reader, 0x05ac (Apple Inc.), 0x8403, 0x26100000 / 2
USB Device: Apple Optical USB Mouse, 0x05ac (Apple Inc.), 0x0304, 0x04100000 / 2
USB Device: Muse Pocket LT3, 0x06f8, 0xc001, 0x06400000 / 5
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x06600000 / 4
USB Device: Bluetooth USB Host Controller, 0x05ac (Apple Inc.), 0x8213, 0x06610000 / 7
USB Device: IR Receiver, 0x05ac (Apple Inc.), 0x8242, 0x06500000 / 3
USB Device: Apple Internal Keyboard / Trackpad, 0x05ac (Apple Inc.), 0x0237, 0x06300000 / 2

[/spoiler]

If there's an obvious reason for this or maybe a solution which I've missed, I'd appreciate it if anyone would share it with me. So at least I know what i'm doing wrong.

Thanks.

#2 _tommo_

    Space Captain

  • Oxeye Games
  • 34 posts

Posted 04 July 2013 - 11:58 AM

Cobalt (because of a bug) still doesn't work on Mac 10.6, but should in the next update :)

#3 Tim_Kb

    Space Captain

  • Members
  • PipPip
  • 38 posts

Posted 04 July 2013 - 01:16 PM

[quote name='_tommo_' timestamp='1372939136' post='32995']
Cobalt (because of a bug) still doesn't work on Mac 10.6, but should in the next update :)
[/quote]

Oh, ok! Thanks for the info :)

#4 darkozzyman

    Space Captain

  • Members
  • PipPip
  • 138 posts

Posted 08 July 2013 - 08:19 PM

Can't wait to play it!

#5 kilmanio

    Space Captain

  • Moderators
  • PipPip
  • 459 posts

Posted 26 July 2013 - 08:47 AM

ah that seems...

[u][b]Nerfed pipe gun slightly[/b][/u]

the (...) oxeye! that was my favorite gun. :(